Prisijungti

Torrent klientai

  • 2 Rugp '10

Sveiki, turiu problemą. Turiu tokį interneto planą:
1. Jis apribotas srautu į užsienį ir iš jo. (8gb)
2. Lietuvoje srautas neribojamas.
3. Jei viršiju srauto limitą interneto greitis labai sulėtėja. (o aš to nenoriu)

Taigi, jei naudojuosi torrentais, tai iš manęs siurbiasi ir lt vartotojai ir užsienio vartotojai. Transmission klientas neturi galimybės stebėti, peer'u buvimo vietas, o deluge turi. Tai naudodamas deluge, dar galiu sustabdyti skleidimą, jei pamatau, kad peer'as ne iš Lietuvos.

Klausimas. Gal žinote, kaip susikurti filtra su Deluge nuo tų peer'ų. Ar kad būtų galimybė atjungti tą, kuris siunčiasi iš manęs. O gal kokį kitą torrent klientą pasiūlysite, kuriame jau būtų panašios funkcijos...

Deluge peer'ų stebėjimas:

starkadon Pedrilio
  • 3 Rugp '10

Pažiūrėjau qBittorrent'e:

yra galimybė užblokuoti peerą:

yra filtrų galimybė, bet nebandžiau, nežinau kaip veikia:

  • 3 Rugp '10

Užtektų ir ban funkcijos, kad ir laikinai, galėtų but filtras koks pagal location(valstybes)

  • 4 Rugp '10

Ačiū, Starka. Geras tas klientas. Ten galima uždėti limitą bet kokiam peer'ui. Super. Deluge su transmission to negali. Atsigavau, nusiraminau

starkadon Pedrilio
  • 4 Rugp '10

Prašom

  • 28 Rugp '10

Ten ta funkcija banina ir ip įrašo į kažkoki failą, tik nelabai susigaudau į kokį, nes niekur nerandu. Gal kas žinote?

  • 2 Kov '12

Sveiki, gal kas nors naudoja Transmission 2.33. Atnaujinus į šią versiją susidūriau su nesklandumais. Užsakydamas torrent, jis labai po ilgo laiko pradeda siųstis tik. Kartais pavyksta pradėti jį siųsti išjungus ir įjungus klientą. Su default Transmission versija (Ubuntu 10.10) buvo kaip ir viskas gerai. Gal kas turite kokių nors minčių?

  • 2 Kov '12

@abrius rašė:
Sveiki, gal kas nors naudoja Transmission 2.33. Atnaujinus į šią versiją susidūriau su nesklandumais.

Sprendžiant iš Change List'o 2.40 versijoje buvo kažkas daroma su "Torrent queuing", galbūt tai tavo minėta problemą buvo bandoma šalinti. Dabartinė versija yra 2.50. Jei labai trukdo gyventi siulau upgreidinti arba downgradint.

  • 2 Kov '12

@apocalipso rašė:
Sprendžiant iš Change List'o 2.40 versijoje buvo kažkas daroma su "Torrent queuing", galbūt tai tavo minėta problemą buvo bandoma šalinti. Dabartinė versija yra 2.50. Jei labai trukdo gyventi siulau upgreidinti arba downgradint.

Oficialiame ubuntu package siūlo ant maverick 2.05, o 2.33 Oneiric, galbūt tai ir būtų bėda ar tai įmanoma? Nors paties Transmissionbt ppa atnaujino pats net maverick'ui iki 2.33 versijos, ne iki 2.50. Kaip supratau belieka kompilinti iš išeities kodo arba nusimušti iki 2.05. O taip visai nusimušti nesinori.

P.s kompiuliuojant nesutampa package versijos
"checking for LIBEVENT... configure: error: Package requirements (libevent >= 2.0.10)" Reikalinas ubuntu LIBEVENT 11.10 arba 12.04 package.
Kaip supratau belieka nenorimas downgrades. ;]

  • 2 Kov '12

@abrius rašė:
P.s kompiuliuojant nesutampa package versijos
"checking for LIBEVENT... configure: error: Package requirements (libevent >= 2.0.10)" Reikalinas ubuntu LIBEVENT 11.10 arba 12.04 package.

Na aš pamėginau tai susikompiliavo be problemų (Ubuntu 11.10). Dariau taip:
```
sudo apt-get install build-essential checkinstall

sudo apt-get install build-essential automake autoconf libtool pkg-config intltool libcurl4-openssl-dev libglib2.0-dev libevent-dev libminiupnpc-dev libminiupnpc5 libappindicator-dev

cd išarchivuotasTransmissionAplankas

./configure -q && make -s

make

sudo checkinstall --fstrans=0
```Kai viskas baigės aplanke radau .deb paketą ir jį sudiegiau.

  • 3 Kov '12

@apocalipso rašė:

@abrius rašė:
P.s kompiuliuojant nesutampa package versijos
"checking for LIBEVENT... configure: error: Package requirements (libevent >= 2.0.10)" Reikalinas ubuntu LIBEVENT 11.10 arba 12.04 package.

Na aš pamėginau tai susikompiliavo be problemų (Ubuntu 11.10). Dariau taip:
```
sudo apt-get install build-essential checkinstall

sudo apt-get install build-essential automake autoconf libtool pkg-config intltool libcurl4-openssl-dev libglib2.0-dev libevent-dev libminiupnpc-dev libminiupnpc5 libappindicator-dev

cd išarchivuotasTransmissionAplankas

./configure -q && make -s

make

sudo checkinstall --fstrans=0
```Kai viskas baigės aplanke radau .deb paketą ir jį sudiegiau.

Tai aš viską irgi taip dariau kaip ir tu, pradžioje tavo variantu, po to pabandžiau per SVN, abiem atvejais nesigavo. Matai nuo 11.10 versijos tik atsiranda tokie paketai kaip libminiupnpc-dev ir libminiupnpc5, bet pas mane 10.10, todėl į juos neinstaliuoja per apt-get install. Matomai todėl kompiliavimas ir stringa, žinoma dar reiktų neužmiršti ir LIBEVENT paketo, kurio 2.0.10 versija irgi tik nuo 11.10 plaukia. Nebandžiau dar praktikoje grūsti per prievartą tokius paketus iš naujesnių versijų, bet man kažkodėl nuojauta kužda, kad tai nelabai pavyktų arba kad nepraslysčiau be problemų.

Atsakyti