Log in

usb wi-fi adapterio diegimas į ubuntu 10,04

  • 22 Nov '11

taigi, nusipirkau naują usb adapterį"tp link tl-wn722n", naudojausi šia instrukcija diegimui: http://dwiel.net/blog/tp-link-tl-wn722n ... ntu-10-04/
parsiunčiau tar'ą, išpakavau, paleidau komandą ./scripts/driver-select ath9k_htc
po to paleidau komandą "make", tris paskutinės išvesties eilutės buvo tokios:
make -c /lib/modules/2.6.32-31-386/build M=/root/desktop/compat-wireless-2.6.38.2-2 modules
make: */lib/modules/2.6.32-31-386/build: no such file or directory. stop.
make: [modules] Error 2

  • 22 Nov '11

kodėl???

  • 1
  • 22 Nov '11

@sasafeda rašė:
kodėl???

Kur tu išpakavai tarbalą?
Be to ar susinstaliavai Linux kernel headers paketą?
Gali bandyti kitas versijas iš:
http://linuxwireless.org/en/users/Download/stable/

  • 22 Nov '11

@enternald rašė:

@sasafeda rašė:
kodėl???

Kur tu išpakavai tarbalą?
Be to ar susinstaliavai Linux kernel headers paketą?

ant desktopo, nemanau, kad suinstalliavau, nebent su updates atėjo

  • 22 Nov '11

aišku
O turi kernel-headers paketą, per synaptic pažiūrėk.

  • 23 Nov '11

@enternald rašė:
aišku
O turi kernel-headers paketą, per synaptic pažiūrėk.

ubuntu headers buvo suinstallintas. pabandžiau parsisiųsti GUI installerį, (nuorodą pamečiau) jis padarė tą patį, ką ir aš bandžiau atlikti per terminalą, tačiau nemetė jokių errorų, aš negaliu pamatyti adapterio, intikas neveikia :/

  • 23 Nov '11

@sasafeda rašė:

@enternald rašė:
aišku
O turi kernel-headers paketą, per synaptic pažiūrėk.

ubuntu headers buvo suinstallintas. pabandžiau parsisiųsti GUI installerį, (nuorodą pamečiau) jis padarė tą patį, ką ir aš bandžiau atlikti per terminalą, tačiau nemetė jokių errorų, aš negaliu pamatyti adapterio, intikas neveikia :/

pajungęs iš karto adapterį suvesk:

sudo modprobe ath9k_htc

ir

dmesg | tail

parodyk ką išmes.

  • 23 Nov '11

štai:http://i1209.photobucket.com/albums/cc400/sasafeda/20111123022.jpg apgailėstauju už tokią kokybę, tik vienas usb kompe veikia

  • 23 Nov '11

Ką matau, kad nesusiinstaliavo, to ir bijojau.
Nebevargk radau ubuntu paketus, susižinok kokią architechtūrą naudoji:
i386 (paprastą ar pae) ar 64 bitų procesorių. Turėtų būti parašytas:

uname -a

Tada iš čia paketą persisiunti: http://packages.ubuntu.com/lucid/linux-backports-modules-compat-wireless-2.6.34-2.6.32-26-generic
Arba iš čia: http://packages.ubuntu.com/lucid/linux-backports-modules-compat-wireless-2.6.34-2.6.32-26-generic-pae, jei naudoji pae branduolį (32 bitų OS mato daugiau nei 4Gb).
Ir viską suinstaliuoji.
Po to atlieki tas pačias procedūras kurias minėjau anksčiau.

  • 24 Nov '11

32 bit os, i686
root@nata-laptop:~# modprobe ath9k_htc
WARNING: All config files need .conf: /etc/modprobe.d/alsa-base, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/blacklist-modem, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/bluez, it will be ignored in a future release.
FATAL: Module ath9k_htc not found.
root@nata-laptop:~# dmesg | tail
[ 309.139715] sd 2:0:0:4: [sdf] Attached SCSI removable disk
[ 309.148441] sd 2:0:0:2: [sdd] Assuming drive cache: write through
[ 309.148460] sdd: sdd1
[ 309.156227] sd 2:0:0:2: [sdd] Assuming drive cache: write through
[ 309.156244] sd 2:0:0:2: [sdd] Attached SCSI removable disk
[ 399.000283] e100: eth0 NIC Link is Up 100 Mbps Full Duplex
[ 399.000895] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 409.504136] eth0: no IPv6 routers present
[ 457.940090] usb 1-1: new high speed USB device using ehci_hcd and address 4
[ 458.089241] usb 1-1: configuration #1 chosen from 1 choice
root@nata-laptop:~#

  • 24 Nov '11

:S ka daryt neisivaizduoju....

  • 24 Nov '11

krč, pažėjau jutubei tutorialą(http://www.youtube.com/watch?v=gk8g1vr2kpA), parsisiunčiau ndis, bandžiau installinti driverį iš disko, pabandžiau visus, kurie ten buvo (win xp, win 7 ir t.t.) ir su visais gavau errorą "invalid driver" fffuuuuuuuu....
ką?, man dėl tokio š kaip usb wireless adapteris reikės keisti os atgal į windblows????

  • 24 Nov '11

Iš to ką matau, matomai tavo prietaisą per USB pagavo, bet jį pajungė kaip flashą, pažiurėk ar neatsirado koks naujas diskas ir spausk unmount, dažnai modemai, tokio tipo įrenginiai, turi talpyklą windows draiveriams, kuri automatiškai, ją reikia atjungti tiktai.
Pažiūrėk ar tavo įrangos nėra čia: http://www.draisberghof.de/usb_modeswitch/device_reference.txt
Jei yra toks ar panašus modelis, tereikia susiinstaliuoti usb_modeswitch paketą.
eth įrenginys dmesg | tail buvo tas vadinasi tavo modemas jau veikia, tik turi persijungti iš saugyklos į adapterio rėžimą.

  • 25 Nov '11

@enternald rašė:
Iš to ką matau, matomai tavo prietaisą per USB pagavo, bet jį pajungė kaip flashą, pažiurėk ar neatsirado koks naujas diskas ir spausk unmount, dažnai modemai, tokio tipo įrenginiai, turi talpyklą windows draiveriams, kuri automatiškai, ją reikia atjungti tiktai.
Pažiūrėk ar tavo įrangos nėra čia: http://www.draisberghof.de/usb_modeswitch/device_reference.txt
Jei yra toks ar panašus modelis, tereikia susiinstaliuoti usb_modeswitch paketą.
eth įrenginys dmesg | tail buvo tas vadinasi tavo modemas jau veikia, tik turi persijungti iš saugyklos į adapterio rėžimą.

ne, tai nebuvo modemas, tai buvo flash drive, o adapteris yra address 4 ir jis mato ji tiesiog kaip "new usb device"

  • 13 Dec '11

ka tik paleidau pas save tp-link TL-WN722N pagal http://dwiel.net/blog/tp-link-tl-wn722n-on-ubuntu-10-04/ gida. Veikia kuo puikiausia. Jei dar nepaleidai tai rasyk. Padesiu kuom galesiu

  • 16 Dec '11

@Artas3d rašė:
ka tik paleidau pas save tp-link TL-WN722N pagal http://dwiel.net/blog/tp-link-tl-wn722n-on-ubuntu-10-04/ gida. Veikia kuo puikiausia. Jei dar nepaleidai tai rasyk. Padesiu kuom galesiu

jau paleidau, perinstalliavau ubuntu, tada viskas pradejo veikti, aciu uz pagalba

Reply