Prisijungti

Žiūrint filmą ar video internete, lagina garsas

  • 5 Vas '12

Problema atsiranda video žiūrint per visą ekraną. Vaizdas geras, bet garsas lagina (arba spragsi). Sumažinus leistuvo langą, problema dingsta ir garsas tampa švarus.

CPU: Pentium D 2.66 GHz
RAM: 2,5 GB
Video: ATI HD4550
OS: Ubuntu 11.10 (Unity)

  • 5 Vas '12

Galbut tavo kompiuteris per silpnas flashui? Ziurejai kiek cpu naudoja ziurint?

  • 5 Vas '12

Pradžiai išjungt arba įjungt flash'e hardware acceleration.

  • 6 Vas '12

Dabar Firefox su 3 atvertom kortelėm naudoja 74% CPU ir ~400MB RAM.
Dar blogiau su filmais. Totem užkrauna CPU iki 100% ir naudoja 50MB RAM. SMPlayer - 80% CPU ir 30MB RAM. Vaizdo ir garso kokybė vienoda (garsas lagina, vaizdas kai kada taip pat lagina).

  • 6 Vas '12

Nesigaudau aš ATI vaizdinių versijavime, tad sunku pasakyti ar vašką galima iš jos išspausti. Kad ir kaip bebūtų panašu kad pas tavęs nėra video akselaracijos, nes labai jau daug į CPU metą.

  • 6 Vas '12

@absys rašė:
Pradžiai išjungt arba įjungt flash'e hardware acceleration.

Kur tai rasti? Adobe Flash Player Preferrences jo nėra.

Įkėliau į Youtube, kaip veikia flash http://youtu.be/aULei34Stnk

  • 6 Vas '12

@sigis rašė:
Kur tai rasti? Adobe Flash Player Preferrences jo nėra.

Mėgink instaliuoti:

sudo apt-get install adobe-flash-properties-gtk

Ir paleidus ieškoti akselaracijos

flash-player-properties

netestavau, tai nežinau ar ten yra tokia opcija.

  • 6 Vas '12

Pelyte užvedi ant ekrano, dešnias pelytės mygtukas Settings>Enable hardware acceliarations.

  • 6 Vas '12

@Vladasl rašė:
Pelyte užvedi ant ekrano, dešnias pelytės mygtukas Settings>Enable hardware acceliarations.

Senokai pastebėjau,jog mano atveju niekas ten nepasispaudžia su pele,su klaviatūra vaikščiot galiu,bet varnelės atžymėt ne.Bet pas mane ir taip viskas tvarkoje

  • 7 Vas '12

@apocalipso rašė:

@sigis rašė:
Kur tai rasti? Adobe Flash Player Preferrences jo nėra.

Mėgink instaliuoti:

sudo apt-get install adobe-flash-properties-gtk

Ir paleidus ieškoti akselaracijos

flash-player-properties

netestavau, tai nežinau ar ten yra tokia opcija.

Synaptic randa tik adobe-flash-properties-gtk. Įdiegtas, bet ten akceleracijos nėra.

Dar Catalyst nustatymuose bandžiau įjungti tear free. Rašo:
http://twitpic.com/8grxcf/full

  • 7 Vas '12

@sigis rašė:
Dar Catalyst nustatymuose bandžiau įjungti tear free. Rašo:
"Tear Free Desktop cannot be enabled due insufficient graphics adapter memory"

Kokia monitoriaus rezoliucija nustatyta? Ir ar bandei testuoti išjungus effektus (ar pakeitus į lengvesnę aplinką)?

  • 7 Vas '12

@apocalipso rašė:

@sigis rašė:
Dar Catalyst nustatymuose bandžiau įjungti tear free. Rašo:
"Tear Free Desktop cannot be enabled due insufficient graphics adapter memory"

Kokia monitoriaus rezoliucija nustatyta? Ir ar bandei testuoti išjungus effektus (ar pakeitus į lengvesnę aplinką)?

1680x1050 (Samsung T220 veikia kaip analog). Bandžiau Unity 2D. Tas pats.

  • 7 Vas '12

Visgi gal čia flashas?
O jei pabandžius?
http://ubuntuforums.org/showpost.php?p= ... ostcount=4
dar neužmirškim ir
https://addons.mozilla.org/en-US/firefo ... flash-aid/
arba instaliavus ankstesne flash versiją - 10.3.

  • 7 Vas '12

Tottem, VLC ir SMPlayer flash'o nenaudoja, o lagina dar labiau. Dėl flash galima pakentėti, bet filmų grotuvus dažnai naudoju. Dabar noriu pažiūrėti vieną filmą. Stringa ir garsas, ir vaizdas.

  • 1
  • 7 Vas '12

@sigis rašė:
Tottem, VLC ir SMPlayer flash'o nenaudoja, o lagina dar labiau.

Aš įtariu kad kažkas ne taip su vaizdine (jos driveriais), gal video akselaracija neveikia. Galima būtų žiūrėti ką sako vainfo sudiegus:

sudo apt-get install xvba-va-driver libva-glx1 vainfo

Papastink koks outputas iš komandos:

vainfo

Jei outpute pasitaikė errorų tikėtina kad video akselaracija neveikia teisingai. Tokiu atveju mėginčiau instaliuoti binarinius ATI driverius iš officialios svetainės. Manau galima sekti ir šias instaliacijos instrukcijas (nepaminėjai, kuriuo budu instaliavai savo driverius).

  • 7 Vas '12

Įdiegiau gnome-session-fallback, atsijungiau ir pasirinkau Gnome Classic (no effects). Atvėriau filmą su Totem. Rodo puikiai, nestringa nei vaizdas, nei garsas.

  • 7 Vas '12

Bandei SMPlayer nustatymuose video išvesties tvarkyklės keist, audio video sinchronizacija, greitaveika?

  • 7 Vas '12

libva: libva version 0.32.0
Xlib: extension "XFree86-DRI" missing on display ":0.0".
libva: va_getDriverName() returns 0
libva: Trying to open /usr/lib/dri/fglrx_drv_video.so
libva: va_openDriver() returns 0
vainfo: VA API version: 0.32
vainfo: Driver version: Splitted-Desktop Systems XvBA backend for VA-API - 0.7.8
vainfo: Supported profile and entrypoints
VAProfileH264High : VAEntrypointVLD
VAProfileVC1Advanced : VAEntrypointVLD

  • 7 Vas '12

@sigis rašė:

libva: libva version 0.32.0
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
libva: va_getDriverName() returns 0
libva: Trying to open /usr/lib/dri/fglrx_drv_video.so
libva: va_openDriver() returns 0
vainfo: VA API version: 0.32
vainfo: Driver version: Splitted-Desktop Systems XvBA backend for VA-API - 0.7.8
vainfo: Supported profile and entrypoints
      VAProfileH264High               :    VAEntrypointVLD
      VAProfileVC1Advanced            :    VAEntrypointVLD

Atrodo viskas kaip ir gerai.. Jei išjungus effektus problemos nebelieka galbūt reiktų lengvesnį desktop enviromentą pasirinkti.

  • 7 Vas '12

@Vladasl rašė:
Bandei SMPlayer nustatymuose video išvesties tvarkyklės keist, audio video sinchronizacija, greitaveika?

Dėkui, dėkui, dėkui. Išvesties tvarkyklę nustačiau gl (greitai - ATI plokštėms). Garsas švarus, rodo puikiai.

Atsakyti