Prisijungti

trn - tiny news reader

  • 1 Rugp '13
sudo apt-get install trn

Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
alpine-doc libbsd0:i386 libdb5.1:i386 libdebian-installer4 libgcrypt11:i386
libgnutls26:i386 libgpg-error0:i386 liblockfile1:i386 libp11-kit0:i386
libpam0g:i386 libpcre3:i386 libpython3.2 libsasl2-2:i386
libsasl2-modules:i386 libselinux1:i386 libsqlite3-0:i386 libssl1.0.0:i386
libtasn1-3:i386 libtextwrap1 mlock python3-uno time:i386 ttf-marvosym
zlib1g:i386
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
anacron gcc-4.7-base:i386 inn2-inews:i386 libc6:i386 libc6-i686:i386
libgcc1:i386 libgpm2:i386 libncurses5:i386 libperl4-corelibs-perl
libpython3.2 libtinfo5:i386 libxfce4ui-1-0 libxfce4util-bin
libxfce4util-common libxfce4util4 libxfconf-0-2 nemo-data python3-uno
shiki-colors-xfwm-theme xfce-keyboard-shortcuts xfconf xfwm4 xfwm4-themes
Suggested packages:
glibc-doc:i386 locales:i386 gpm:i386 gnome-colors shiki-colors ispell:i386
xfce4
Recommended packages:
mail-transport-agent:i386
The following packages will be REMOVED:
alpine apache2.2-bin apt-file aptdaemon aptoncd apturl at avahi-daemon
banshee banshee-extension-soundmenu bind9-host build-essential cinnamon
cli-common colord command-not-found console-setup console-setup-linux cowsay
cpufrequtils crda cron cryptsetup cups cups-client cups-driver-gutenprint
ddm debconf-i18n discover dnsutils docbook-xml dpkg-dev fetchmail
firmware-ipw2x00 firmware-ivtv flashplugin-nonfree flex foomatic-db-engine
foomatic-filters foomatic-filters-ppds fuse fuse-utils
gconf-defaults-service gconf-editor gdebi ghc-doc gir1.2-muffin-3.0 gksu
gnome-control-center gnome-panel gnome-screensaver gnome-session-fallback
grub-pc gstreamer0.10-plugins-bad gthumb gthumb-data gufw hal hddtemp hpijs
hplip hunspell-en-us inn2-inews iputils-ping latex-beamer latex-xcolor
libalgorithm-diff-perl libalgorithm-diff-xs-perl libalgorithm-merge-perl
libapache2-mod-dnssd libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap
libapt-pkg-perl libart2.0-cil libavahi1.0-cil libbind9-60 libbind9-80
libboo2.0.9-cil libc-client2007e libcairo-perl libcheese-gtk21 libcheese3
libclass-accessor-perl libconfig-file-perl libdbus-glib1.0-cil
libdbus1.0-cil libdns69 libdns81 libdpkg-perl libdpkg-ruby1.8 libecal-1.2-10
libecal-1.2-11 libecal1.2-7 libecal1.2-8 libedata-cal-1.2-13
libedata-cal-1.2-15 libedata-cal1.2-10 libedata-cal1.2-7
libedataserverui-3.0-1 libencode-locale-perl libfarstream-0.1-0
libfile-copy-recursive-perl libfile-fcntllock-perl libfile-listing-perl
libflickrnet2.2-cil libfont-afm-perl libgconf2.0-cil libgdata1.7-cil
libgdata1.9-cil libgdata2.1-cil libgkeyfile1.0-cil libglade2.0-cil
libgladeui-1-9 libglib-perl libglib2.0-cil libgmime2.4-cil libgmime2.6-cil
libgnome-keyring1.0-cil libgnome-vfs2.0-cil libgnome2-canvas-perl
libgnome2-perl libgnome2-vfs-perl libgnome2.24-cil libgs8
libgtk-sharp-beans-cil libgtk2-perl libgtk2.0-cil libgudev1.0-cil libhpmud0
libhtml-format-perl libhtml-parser-perl libhtml-tagset-perl
libhtml-template-perl libhtml-tree-perl libhttp-cookies-perl
libhttp-date-perl libhttp-message-perl libhttp-negotiate-perl libical0
libimobiledevice1 libio-socket-ssl-perl libio-string-perl libisccfg62
libisccfg82 liblist-moreutils-perl liblwp-mediatypes-perl
liblwp-protocol-https-perl libmailtools-perl libmetacity-private0a
libmono-addins-gui0.2-cil libmono-addins0.2-cil libmono-zeroconf1.0-cil
libmuffin0 libndesk-dbus-glib1.0-cil libndesk-dbus1.0-cil libnet-dbus-perl
libnet-http-perl libnet-ssleay-perl libnewtonsoft-json4.5-cil
libnotify0.4-cil libnss-mdns liboobs-1-4 liboobs-1-5 libpam-cap
libpam-ck-connector libpam-gnome-keyring libpango-perl libpango1.0-common
libpaper-utils libparse-debianchangelog-perl libperl5.14 libpolkit-gtk-1-0
libpurple-bin libpurple0 libregexp-assemble-perl libreoffice
libreoffice-base libreoffice-base-core libreoffice-calc libreoffice-draw
libreoffice-emailmerge libreoffice-impress libreoffice-math
libreoffice-report-builder-bin libreoffice-style-tango libreoffice-writer
libruby libsane libsane-hpaio libsasl2-modules libsnmp15 libsub-name-perl
libtaglib2.0-cil libtext-charwidth-perl libtext-wrapi18n-perl
libtie-ixhash-perl libtimedate-perl libuniconf4.6 liburi-perl libuuid-perl
libwvstreams4.6-extras libwww-perl libwww-robotrules-perl
libxml-namespacesupport-perl libxml-parser-perl libxml-parser-ruby1.8
libxml-sax-base-perl libxml-sax-expat-perl libxml-sax-perl
libxml-simple-perl libxml-twig-perl linux-base linux-image-3.2.0-4-amd64
linux-image-amd64 lm-sensors lmodern luatex mdm metacity metacity-common
mint-debian-mirrors mint-meta-debian-cinnamon mint-meta-debian-core
mintinstall mintstick mintsystem mintupdate-debian mintwelcome mlocate
muffin-common nemo nemo-fileroller network-manager network-manager-gnome
network-manager-pptp network-manager-pptp-gnome nn ntfs-3g ntfsprogs ntp
openssh-client opera pgf pidgin pidgin-facebookchat plymouth-drm
plymouth-themes-mint plymouth-x11 policykit-1 policykit-1-gnome portmap ppp
pppconfig pppoe pppoeconf pptp-linux preview-latex-style
printer-driver-foo2zjs printer-driver-gutenprint printer-driver-hpcups
printer-driver-hpijs printer-driver-m2300w printer-driver-postscript-hp
printer-driver-pxljr printer-driver-splix prosper ps2eps pulseaudio
pulseaudio-esound-compat pulseaudio-module-gconf pulseaudio-module-x11
pulseaudio-module-zeroconf python-aptdaemon python-aptdaemon.gtk3widgets
python-evolution python-opencv python-openssl python-pam python-qt4
python-uno rarian-compat resolvconf rsync rtkit ruby-debian ruby-xmlparser
samba samba-common samba-common-bin sane-utils sgml-base sgml-data
shiki-colors-metacity-theme shiki-wise-theme simple-scan
software-properties-gtk ssl-cert ssmtp sudo system-tools-backends tex-common
tex-gyre texlive texlive-base texlive-binaries texlive-common
texlive-doc-base texlive-extra-utils texlive-font-utils
texlive-fonts-recommended texlive-fonts-recommended-doc
texlive-generic-recommended texlive-latex-base texlive-latex-base-doc
texlive-latex-extra texlive-latex-extra-doc texlive-latex-recommended
texlive-latex-recommended-doc texlive-luatex texlive-pictures
texlive-pictures-doc texlive-pstricks texlive-pstricks-doc time tipa tomboy
trn4 ufw update-inetd user-setup uuid-runtime uw-mailutils
virtualbox-guest-dkms virtualbox-guest-utils virtualbox-guest-x11 w3m
wpasupplicant wvdial x-ttcidfont-conf xchat xml-core
The following NEW packages will be installed:
anacron gcc-4.7-base:i386 inn2-inews:i386 libc6:i386 libc6-i686:i386
libgcc1:i386 libgpm2:i386 libncurses5:i386 libperl4-corelibs-perl
libpython3.2 libtinfo5:i386 libxfce4ui-1-0 libxfce4util-bin
libxfce4util-common libxfce4util4 libxfconf-0-2 python3-uno
shiki-colors-xfwm-theme trn:i386 xfce-keyboard-shortcuts xfconf xfwm4
xfwm4-themes
The following packages will be upgraded:
nemo-data
1 upgraded, 23 newly installed, 342 to remove and 9 not upgraded.
Need to get 11.7 MB of archives.
After this operation, 1,629 MB disk space will be freed.
Do you want to continue [Y/n]? Abort.

lol wut?
trn - tiny usenet news reader.
Linux Mint debian cinamon distribucija.

As aisku iprates net neziuredamas spausti `y' instaliuodamas, na bet kas per daug tai per daug. Idomumo delei reiketu paziureti rezultata.
trn4 susinstaliavosi normaliai.

TechtronicMindaugas N.
  • 1 Rugp '13

Sunku atsakyti, gal daugiau informacijos rasys sios komandos:

apt-cache show trn

Arba:

apt-cache depends trn

Debian based, tai gal aptitude turi:

aptitude show trn

Bandau rasti http://packages.linuxmint.com/search.php, bet tokios package nera arba search neveikia...

Tokia problema turejau kadaise, net juokemes visi darbe, kad norint uninstall ubuntu gali parasius komanda: apt-get remove gedit.

TechtronicMindaugas N.
  • 1 Rugp '13

trn -

Jeigu reikia RSS/Atom feed reader, tai noreciau rekomenduoti QuiteRSS.

http://code.google.com/p/quite-rss/

Na o jeigu NewsGroup sekti geriau GNU/Linuxe kaip Knode neradau

  • 1 Rugp '13

Taigi pabandziau vis delto ivykdyti trn instaliacija.

  1. Etapas, rasom sudo apt-get install trn ir sutinkam kad sudirbtu sistema, instaliacija sustojo po nepavykusio initramfs rodos, ar kazkas panasaus. Na apsidziaugiau ir parasiau kosoleje trn, ir gavau pranesima kad sita programa dar nerasta
  2. Etapas vel rasom sudo apt-get install trn, pirmas idomus pranesimas kai ismete melyna langa ir paklause ar tikrai noriu istrinti linux kernel 3.xxx kadangi ji dabar ir naudoju , pasakiau kad abort, veliau dar vienas pranesimas kad sistema reikes perkrauti, nu ok.
  3. Kompiuteris persikrauna ir po grub pasirinkimo ir keliu krovimosi eiluciu gaunu juoda ekrana
  4. Pasirenku recovery mod grube, rezultatas vis tiek juodas ekranas (siek tiek sviecia apsvietimo lempa LCD ekrane) kuris nenori i kazka daugiau reguoti.

P.S kazkokios bedos nera, kadangi Linux Mint Cinamon buvo instaliuota atskiram harde siaip pasiziurejimui.

apt-cache show trn

Package: trn
Version: 3.6-23
Installed-Size: 536
Maintainer: Matthew Vernon matthew@debian.org
Architecture: i386
Provides: news-reader
Depends: libc6 (>= 2.7), libncurses5 (>= 5.7+20100313), inews | inewsinn, debconf (>= 0.5)
Recommends: mail-transport-agent
Suggests: ispell
Description-en: Threaded USENET news reader, based on rn
trn is the most widely-used newsreader on USENET - even to the
point of being a de-facto standard. It has a powerful full screen
text mode user interface, where most actions are available at the
press of a single key. It is highly configurable.
.
This version of trn reads news from a news server via NNTP (the
Network News Transfer Protocol). You must have a news server
available - large sites usually provide a site-wide server.
.
If you install a news server on your system (either containing
just local newsgroups or with a partial or full USENET feed) you
can configure trn to access it.
Description-md5: e4ce6da4992e53e921b2a02837414e95
Tag: network::client, protocol::nntp, role::program, uitoolkit::ncurses
Section: non-free/news
Priority: optional
Filename: pool/non-free/t/trn/trn_3.6-23_i386.deb
Size: 224402
MD5sum: 57782e66c4bf127af0d252db9439fbdf
SHA1: 3de30ca698944da0c429a1b2d40eb26db0dbffc2
SHA256: fd24fea56e76c6e4639d40de8b1772556facb757ed2009abc4fa4e682bb82387

apt-cache depends trn

trn:i386
Depends: libc6:i386
Depends: libncurses5:i386
|Depends: inews:i386
inn:i386
inn2-inews:i386
Depends: inewsinn:i386
Depends: debconf:i386
debconf
Suggests: ispell:i386
Recommends: mail-transport-agent:i386
citadel-mta:i386
courier-mta:i386
masqmail:i386
nullmailer:i386
postfix:i386
sendmail-bin:i386
ssmtp:i386
xmail:i386
dma:i386
dma
exim4-daemon-heavy:i386
exim4-daemon-light:i386

  • 1 Rugp '13

Asmeniskai naudoju alpine programa usenet naujienoms

Pliusai:
Veikia tiek windows tiek *nyx
konfiguracini faila, galima saugoti IMAP serveryje
NNTP naujienas galima persiusti i savo pasto dezute (ir naudoti visas pasto laiskams skirtas funkcijas (filtracija/rusiavimas/ieskojimas/etc...)

Kitaip tariant usenet naujienos kurias skaitai bus kaip ir sinchronizuotos per visus kompiuterius(windows/*nyx) is kuriu su alpine(ar kita pasto programa) gali skaityti.

TechtronicMindaugas N.
  • 20 Rugp '13

Perasiau savo Gentoo, su SELinux, Systemd ir tt, dabar butu saunu isirasyti normalu usenet reader, gal gali parekomenduoti normalesni, tik ne curses ?

Atsakyti