Prisijungti

Ubuntu 14.04 VPS error'as

  • 25 Lie

Sveiki nariai, susidūriau su ubuntu 14.04 error'u. Jį matyti turėtumėte prie paveikslėlių. Beveik kiekvieną kartą instaliuojant kažką šį errorą metą ir nesu užtikrintas ar man programą į ubuntu 14.04 VPS instaliavo. Perrašius OS - taip pat, ant kito hostingo VPS turėjau Debian lyg irgi tas pats buvo. Gal galite padėti?Untitled.png

TechtronicMindaugas N.
  • 29 Lie

Taip nutinka todel, kad naudojamas "ubuntu 14.04 VPS" neturi su savimi "dialog" kuris reikalingas tam, kad sutvarkyti MySQL.

apt install dialog

Arba nesuk galvos, instaliuok CentOS :-).

  • 30 Lie

Na cent os negaliu instaliuoti, nes projektas ne mano (mc projektas), esu pakankamai vidutiniokas ant VPS, ir tai mc servą pavyko paleisti tik iš ~30 sykio ir kas bus jeigu ant kitos OS bus.. Vėl teks laukti projekto savininkui kaip prieštai... :) Na o duomenų bazės reikia sms sistemai ir web dalykams. :) Pabandysiu instaliuoti ta dialog... :) Ačiū už... ..žinai ką :D

  • 1
  • 30 Lie

Pavyko instaliuoti, prisiminiau, kad apt-get update buvau nepadaręs.. :)

TechtronicMindaugas N.
  • 30 Lie

@DirGemy sakė:
Pavyko instaliuoti, prisiminiau, kad apt-get update buvau nepadaręs.. :)

Right, dialog naudojamas tam kad paruostu MySQL naudojimui:

Jeigu apt rase klaida, ir po apt update + apt install dialog vis dar apt raso klaida tai gal pades komanda:
# dpkg --configure -a

Kad pakartotinai paleisti MySQL setup skriptus gali su komanda:
# dpkg-reconfigure mysql-server

Patikrinti ar veikia MySQL:

# mysqladmin -u root -p status
Enter password: 
Uptime: 542161  Threads: 1  Questions: 70868  Slow queries: 0  Opens: 77  Flush tables: 1  Open tables: 71  Queries per second avg: 0.060
  • 3 Rugp

Pabandysiu, dabar tik norejau pranesti to ko neisaiskinau anksciau, kad pavyko tik dialog irasyti o mysql - ne. :) Del atsargos parasau :)

  • 3 Rugp

Tai dabar noreciau dar paklausti.. Pries vedant tavo pateiktas komandas isiinstaliuoti pirma visus mysql/phpmyadmin ir tik tada vesti tavo pateiktas komandas.. Ar pries? Ar instaliuoti, jeigu neveikia rasyti tavo pateiktas komandas ir vel instaliuoti?

TechtronicMindaugas N.
  • 3 Rugp

@DirGemy sakė:
Tai dabar noreciau dar paklausti.. Pries vedant tavo pateiktas komandas isiinstaliuoti pirma visus mysql/phpmyadmin ir tik tada vesti tavo pateiktas komandas.. Ar pries? Ar instaliuoti, jeigu neveikia rasyti tavo pateiktas komandas ir vel instaliuoti?

apt-get (arba tik apt) komanda pati automatiskai paleidzia tas komandas tam, kad sutvarkytu/paruostu MySQL (bei daugeli kitu biblioteku/programu) naudojimui.

Tarkim apt install phpmyadmin turi instaliuoti php, Apache httpd(?), bei sioms programoms veikti bibliotekas + jas paruosti jog veiktu out of the box:

  • Sugeneruojama Apache httpd konfiguracija.
  • Sutvarkoma automatiskai php + MySQLi(?) modulis kuris automatiskai bus aktyvuotas (kad veiktu phpMyAdmin).
  • Sukuriama/paruosiama MySQL duomenu baze kad veiktu pats MySQL bei phpMyAdmin, nustatomi slaptazodziai (kam ir yra reikalingas dialog).

Visas tas procesas padaromas automatiskai, tik kartais tenka paciam nurodyti slaptazodi tokiam kaip MySQL ir panasiai, kam ir yra reikalingas dialog :-)

Jusu atveju jeigu MySQL veikia, tai ir naudokit i sveikata, nereikia jokiu vesti papildomu komandu.

Atsakyti