Prisijungti

OpenVz branduolio atnaujinimas

nerijus_sNerijus
  • 25 Bir

Yra čia išmanančių OpenVz ? Yra poreikis atnaujinti serverio openvz branduolį iš 2.6.32 į naujausią stabilią(reikalinga galimybė pasileisti docker arba kubernetes konteinerius CI/CD realizavimui). Dabar serveryje sukasi nemažai konteinerių(pbx, monitoringas ir daug developmentui skirtų kontenerių), todėl viską kas yra reikėtų išsaugoti, bet to pats serveris turi nemažai custom konfiguracijų - jas irgi reiktų išsaugoti. Todėl ieškau žmogaus kuris tikrai gerai išmanytų linux ir openvz. Žinoma ne už ačiū.

  • 3
  • 26 Bir

Nesuprantu, tu nori atnaujinti virtualkėj kernel'į? Jei taip - tai nieko nebus, nes turi būti atnaujintas kernel'is Host (serveryje, kuriame paleistos tavo openvz virtualkės).

Taip pat, jeigu yra minčių viską perkelti į Docker ir orchestruoti konteinerius su Kubernetes - kam tas OpenVZ tau apskritai reikalingas?

nerijus_sNerijus
  • 27 Bir

Niekas apie virtulkę nešneką, kalbu apie fizinį serverį ir jame esančio branduolio atnaujinimą.

TechtronicMindaugas N.
  • 1
  • 27 Bir

Nu ir as nesuprantu, 2.6.32 ir yra stable Linux/OpenVz kernelis, bet speju jog susidurta su problema kai Docker 1.10+ atsisako veikti su 2.6.32* Linux.'u, kas yra visai normalu.

Galima paciam susirinkti OpenVz Linux'a (tik kazin ar toki buda stable galima vadinti), pamenu .config'as ir patch'ai yra public.

P.S NE, surinkti kerneli arba paleisti OpenVz dar padeti galiu, bet dig'inti kazkieno "custom" reikalus po /etc* neturiu nei laiko nei noro.

bacarrdyJonas S.
  • 23 Rugp

Openvz legacy o tai yra 6 naudoja rhel 6 kernelį kuris yra šiai dienai palaikomas bei stabilus.
Norint naudoti dokerius openvz sistemoje - konteineris turi būti sukonfiguruotas su bridged tinklu.
Kaip ir minėjo šioje temoje po tam tikros docker versijos 2.6.32 kernelio dockeriai nebepalaiko.

Įsidiek openvz 7 arba naudok kitą virtualizaciją pvz KVM ir galėsi naudoti dokerius

Atsakyti